Provided by: mailscanner_4.46.2-3_all bug

NAME

       upgrade_MailScanner_conf - upgrades MailScanner.conf config files

SYNOPSIS

       upgrade_MailScanner_conf [--keep-comments] MailScanner.conf
       MailScanner.conf.newversion > MailScanner.conf.new

       RPM === If you are using the RPM distributions then try this:

       cd /etc/MailScanner

       upgrade_MailScanner_conf MailScanner.conf MailScanner.conf.rpmnew >
       MailScanner.new

       mv MailScanner.conf MailScanner.old

       mv MailScanner.new  MailScanner.conf

       TAR === If you are using the tar distribution so that the old version
       is in /opt/MailScanner and the new one is in /opt/MailScanner.new then:

       cd /opt/MailScanner.new/etc

       ../bin/upgrade_MailScanner_conf /opt/MailScanner/etc/MailScanner.conf
       /opt/MailScanner.new/etc/MailScanner.conf > MailScanner.new

       mv MailScanner.conf MailScanner.old

       mv MailScanner.new  MailScanner.conf

DESCRIPTION

       upgrade_MailScanner_conf helps automate the conversion of older
       MailScanner.conf config files to the version of MailScanner you are
       installing.  This takes care of adding any new config items that need
       to be added, removing old deprecated items and updating the comments,
       unless you specify --keep-comments to signal you want your old comments
       left.

OPTIONS

       --keep-comments - tells the script to not update the comments that have
       changed.

       Using --keep-comments can cause you to not realize that there are
       new/more options available to you for the item that your old comment
       was kept with.

AUTHOR

       Julian Field (mailto: Jules@JulianField.net )

SEE ALSO

       perl(1), MailScanner(3)