Provided by: libperl-prereqscanner-perl_1.023-1_all bug

NAME

       Perl::PrereqScanner::Scanner - something that scans for prereqs in a Perl document

VERSION

       version 1.023

DESCRIPTION

       This is a role to be composed into classes that will act as scanners plugged into a
       Perl::PrereqScanner object.

       These classes must provide a "scan_for_prereqs" method, which will be called like this:

         $scanner->scan_for_prereqs($ppi_doc, $version_requirements);

       The scanner should alter the CPAN::Meta::Requirements object to reflect its findings about
       the PPI document.

AUTHORS

       ·   Jerome Quelin

       ·   Ricardo Signes <rjbs@cpan.org>

COPYRIGHT AND LICENSE

       This software is copyright (c) 2009 by Jerome Quelin.

       This is free software; you can redistribute it and/or modify it under the same terms as
       the Perl 5 programming language system itself.