Provided by: libtest-simple-perl_1.302167-1_all bug

NAME

       Test2::API::Breakage - What breaks at what version

DESCRIPTION

       This module provides lists of modules that are broken, or have been broken in the past,
       when upgrading Test::Builder to use Test2.

FUNCTIONS

       These can be imported, or called as methods on the class.

       %mod_ver = upgrade_suggested()
       %mod_ver = Test2::API::Breakage->upgrade_suggested()
           This returns key/value pairs. The key is the module name, the value is the version
           number. If the installed version of the module is at or below the specified one then
           an upgrade would be a good idea, but not strictly necessary.

       %mod_ver = upgrade_required()
       %mod_ver = Test2::API::Breakage->upgrade_required()
           This returns key/value pairs. The key is the module name, the value is the version
           number. If the installed version of the module is at or below the specified one then
           an upgrade is required for the module to work properly.

       %mod_ver = known_broken()
       %mod_ver = Test2::API::Breakage->known_broken()
           This returns key/value pairs. The key is the module name, the value is the version
           number. If the installed version of the module is at or below the specified one then
           the module will not work. A newer version may work, but is not tested or verified.

SOURCE

       The source code repository for Test2 can be found at
       http://github.com/Test-More/test-more/.

MAINTAINERS

       Chad Granum <exodist@cpan.org>

AUTHORS

       Chad Granum <exodist@cpan.org>

COPYRIGHT

       Copyright 2019 Chad Granum <exodist@cpan.org>.

       This program is free software; you can redistribute it and/or modify it under the same
       terms as Perl itself.

       See http://dev.perl.org/licenses/