Provided by: libtest2-suite-perl_0.000125-1_all bug

NAME

       Test2::Require::Module - Skip tests if certain packages are not installed, or insufficient
       versions.

DESCRIPTION

       Sometimes you have tests that are nice to run, but depend on tools that may not be
       available. Instead of adding the tool as a dep, or making the test always skip, it is
       common to make the test run conditionally. This package helps make that possible.

       This module is modeled after Test::Requires. The difference is that this module is based
       on Test2 directly, and does not go through Test::Builder.  Another difference is that the
       packages you check for are not imported into your namespace for you. This is intentional.

SYNOPSIS

           # The test will be skipped unless Some::Module is installed, any version.
           use Test2::Require::Module 'Some::Module';

           # The test will be skipped unless 'Other::Module' is installed and at
           # version '5.555' or greater.
           use Test2::Require::Module 'Other::Module' => '5.555';

           # We now need to use them directly, Test2::Require::Module does not import
           # them for us.
           use Some::Module;
           use Other::Module;

SOURCE

       The source code repository for Test2-Suite can be found at
       https://github.com/Test-More/Test2-Suite/.

MAINTAINERS

       Chad Granum <exodist@cpan.org>

AUTHORS

       Chad Granum <exodist@cpan.org>

COPYRIGHT

       Copyright 2018 Chad Granum <exodist@cpan.org>.

       This program is free software; you can redistribute it and/or modify it under the same
       terms as Perl itself.

       See http://dev.perl.org/licenses/