Provided by: libtest-valgrind-perl_1.19-1_all bug

NAME

       Test::Valgrind::Version - Object class for valgrind versions.

VERSION

       Version 1.19

DESCRIPTION

       This class is used to parse, store and compare "valgrind" versions.

METHODS

   "new"
           my $vg_version = Test::Valgrind::Version->new(
            command_output => qx{valgrind --version},
           );

           my $vg_version = Test::Valgrind::Version->new(
            string => '1.2.3',
           );

       Creates a new Test::Valgrind::Version object representing a "valgrind" version from one of
       these two sources :

       ·   if the "command_output" option is specified, then "new" will try to parse it as the
           output of "valgrind --version".

       ·   otherwise the "string" option must be passed, and its value will be parsed as a
           'dotted-integer' version number.

       An exception is raised if the version number cannot be inferred from the supplied data.

OVERLOADING

       This class overloads numeric comparison operators ("<=>", "<", "<=", " == ", "=>" and
       ">"), as well as stringification.

SEE ALSO

       Test::Valgrind.

AUTHOR

       Vincent Pit, "<perl at profvince.com>", <http://www.profvince.com>.

       You can contact me by mail or on "irc.perl.org" (vincent).

BUGS

       Please report any bugs or feature requests to "bug-test-valgrind at rt.cpan.org", or
       through the web interface at
       <http://rt.cpan.org/NoAuth/ReportBug.html?Queue=Test-Valgrind>.  I will be notified, and
       then you'll automatically be notified of progress on your bug as I make changes.

SUPPORT

       You can find documentation for this module with the perldoc command.

           perldoc Test::Valgrind::Component

COPYRIGHT & LICENSE

       Copyright 2015,2016 Vincent Pit, all rights reserved.

       This program is free software; you can redistribute it and/or modify it under the same
       terms as Perl itself.