Provided by: debhelper_12.6.1ubuntu2_all bug

NAME

       debhelper-obsolete-compat - List of no longer supported compat levels

SYNOPSIS

       This document contains the upgrade guidelines from all compat levels which are no longer
       supported.  Accordingly it is mostly for historical purposes and to assist people
       upgrading from a non-supported compat level to a supported level.

       For upgrades from supported compat levels, please see debhelper(7).

UPGRADE LIST FOR COMPAT LEVELS

       The following is the list of now obsolete compat levels and their changes.

       v1  This is the original debhelper compatibility level, and so it is the default one. In
           this mode, debhelper will use debian/tmp as the package tree directory for the first
           binary package listed in the control file, while using debian/package for all other
           packages listed in the control file.

           This mode is deprecated.

       v2  In this mode, debhelper will consistently use debian/package as the package tree
           directory for every package that is built.

           This mode is deprecated.

       v3  This mode works like v2, with the following additions:

           -       Debhelper config files support globbing via * and ?, when appropriate. To turn
                   this off and use those characters raw, just prefix with a backslash.

           -       dh_makeshlibs makes the postinst and postrm scripts call ldconfig.

           -       Every file in etc/ is automatically flagged as a conffile by dh_installdeb.

           This mode is deprecated.

       v4  Changes from v3 are:

           -       dh_makeshlibs -V will not include the Debian part of the version number in the
                   generated dependency line in the shlibs file.

           -       You are encouraged to put the new ${misc:Depends} into debian/control to
                   supplement the ${shlibs:Depends} field.

           -       dh_fixperms will make all files in bin/ directories and in etc/init.d
                   executable.

           -       dh_link will correct existing links to conform with policy.

           This mode is deprecated.

       v5  This is the lowest supported compatibility level.

           Changes from v4 are:

           -       Comments are ignored in debhelper config files.

           -       dh_strip --dbg-package now specifies the name of a package to put debugging
                   symbols in, not the packages to take the symbols from.

           -       dh_installdocs skips installing empty files.

           -       dh_install errors out if wildcards expand to nothing.

SEE ALSO

       debhelper(7)

AUTHORS

       Niels Thykier <niels@thykier.net>

       Joey Hess