Provided by: debhelper_12.6.1ubuntu2_all bug

NOME

       debhelper-obsolete-compat - Lista dos níveis de compatibilidade não mais suportados

RESUMO

       Este documento contém o guião de actualização a partir de todos os níveis de
       compatibilidade que já não são suportados. Consequentemente é principalmente para
       objectivos históricos e para ajudar pessoas a actualizarem a partir de um nível de
       compatibilidade não suportado para um nível suportado.

       Para actualizações a partir de níveis de compatibilidade suportados, por favor veja
       debhelper(7).

ACTUALIZAÇÃO DE LISTA PARA NÍVEIS DE COMPATIBILIDADE

       O seguinte é a lista dos níveis de compatibilidade agora obsoletos e as suas alterações.

       v1  Este é o nível de compatibilidade original do debhelper, e por isso é o predefinido.
           Neste modo, o debhelper irá usar debian/tmp como o directório da árvore do pacote para
           o primeiro pacote binário listado no ficheiro de controle, enquanto usa debian/pacote
           para todos os outros pacotes listados no ficheiro control.

           Este modo está descontinuado.

       v2  Neste modo, o debhelper irá consistentemente usar debian/pacote como o directório da
           árvore do pacote para cada pacote que é compilado.

           Este modo está descontinuado.

       v3  Este modo funciona como v2, com as seguintes adições:

           -       Os ficheiros de configuração do debhelper suportam englobamentos via * e ?,
                   onde apropriado. Para desligar isto e usar esses caracteres a cru, basta
                   antecedê-los com uma barra invertida (backslash "").

           -       dh_makeshlibs faz com que os scripts postinst e postrm chamem ldconfig.

           -       Qualquer ficheiro em etc/ é marcado automaticamente como um conffile (ficheiro
                   de configuração) pelo dh_installdeb.

           Este modo está descontinuado.

       v4  As alterações a partir de v3 são:

           -       dh_makeshlibs -V não irá incluir a parte Debian do número de versão na linha
                   de dependência gerada no ficheiro shlibs.

           -       Você é encorajado a colocar o novo ${misc:Depends} em debian/control para
                   suplementar o campo ${shlibs:Depends}.

           -       dh_fixperms irá tornar em executáveis todos os ficheiros nos directórios bin/
                   e em etc/init.d.

           -       dh_link irá corrigir os links existentes para ficarem em conformidade com a
                   politica.

           Este modo está descontinuado.

       v5  Este é o nível de compatibilidade mais baixo suportado.

           As alterações a partir de v4 são:

           -       Comentários são ignorados nos ficheiros de configuração do debhelper.

           -       Agora dh_strip --dbg-package especifica o nome de um pacote onde colocar
                   símbolos de depuração, e não os pacotes de onde tirar os símbolos.

           -       dh_installdocs evita a instalação de ficheiros vazios.

           -       dh_install resulta em erro se as "wildcards" expandirem para nada.

VEJA TAMBÉM

       debhelper(7)

AUTORES

       Niels Thykier <niels@thykier.net>

       Joey Hess

TRADUÇÃO

       Américo Monteiro

       Se encontrar algum erro na tradução deste documento, por favor comunique para Américo
       Monteiro a_monteiro@gmx.com ou Equipa Debian de Tradução Portuguesa traduz@debianpt.org.