Provided by: grid-packaging-tools_3.5-2_all bug

NAME

       gpt-install - Installs GPT packages.

SYNOPSIS

       gpt-install [options] [packages or bundles]

         Options:
            -verbose              Print copious output
            -help                 Print usage
            -man                  Print man page.
            -version              Print GPT version.
            -force                Replace package no matter what.
            -loose                Replace a broader range of packages.
            -installdir=PATH      Override $GLOBUS_LOCATION.
            -tmpdir=PATH          Path to tmp disk space
            [packages or bundles] List of binary packages and bundles to install.

DESCRIPTION

       gpt-install takes a GPT described package or bundle and installs it. The program can
       install either RPM's or GPT packages.

OPTIONS

       -force  forces all action to be taken, regardless of state.

       -tmpdir Place to unpack bundles.

       -installdir
               Directory to which files shall be written. Default is $GLOBUS_LOCATION

       -loose  pgm packages can replace a pgm_static package (and vice versa) or a pgm package
               with a different flavor.

       -help   Print a brief help message and exits.

       -man    Prints the manual page and exits.

       -version
               Prints the version of GPT and exits.

EXAMPLES

       For the command:

         gpt-install foo-2.1-gcc32-pgm.tar.gz

         foo-1.1-gcc32-pgm will be replaced.
         foo-2.2-gcc32-pgm will B<not> be replaced. It is newer.
         foo-1.1-vendorcc32-pgm will B<not> be replaced. Wrong flavor.
         foo-1.1-gcc32-pgm_static will B<not> be replaced. Wrong package type
         foo-2.2-gcc32-pgm_static will B<not> be replaced. Wrong package type

       For the command:

         gpt-install -force foo-2.1-gcc32-pgm.tar.gz

         foo-1.1-gcc32-pgm will be replaced.
         foo-2.2-gcc32-pgm will be replaced.
         foo-1.1-vendorcc32-pgm will B<not> be replaced. Wrong flavor
         foo-1.1-gcc32-pgm_static will B<not> be replaced. Wrong package type
         foo-2.2-gcc32-pgm_static will B<not> be replaced. Wrong package type

       For the command:

         gpt-install -loose foo-2.1-gcc32-pgm.tar.gz

         foo-1.1-gcc32-pgm will be replaced.
         foo-2.2-gcc32-pgm will B<not> be replaced. It is newer.
         foo-1.1-vendorcc32-pgm will be replaced.
         foo-1.1-gcc32-pgm_static will be replaced.
         foo-2.2-gcc32-pgm_static will B<not> be replaced. It is newer.

       For the command:

         gpt-install -force -loose foo-2.1-gcc32-pgm.tar.gz

         foo-1.1-gcc32-pgm will be replaced.
         foo-2.2-gcc32-pgm will be replaced.
         foo-1.1-vendorcc32-pgm will be replaced.
         foo-1.1-gcc32-pgm_static will be replaced.
         foo-2.2-gcc32-pgm_static will be replaced.

BUGS

       gpt-install currently does not honor static build numbers.  Instead it will replace any
       pgm_static package that is the same version or older.  For example:

         gpt-install -force foo-2.1-2-gcc32-pgm_static.tar.gz

         foo-1.1-5-gcc32-pgm_static will be replaced.
         foo-2.1-1-gcc32-pgm_static will be replaced.
         foo-2.1-5-gcc32-pgm_static will be replaced.
         foo-2.2-1-gcc32-pgm_static will not be replaced.
         foo-2.1-gcc32-pgm will not be replaced.

SEE ALSO

       gpt-uninstall(1) gpt-query(1) gpt-verify(1)

AUTHOR

       Michael Bletzinger <mbletzin.ncsa.uiuc.edu> and Eric Blau <eblau.ncsa.uiuc.edu>