Ubuntu Manpages

ldns_key_list_new, ldns_key_list_push_key, ldns_key_list_pop_key,

#include <stdint.h>
#include <stdbool.h>

#include <ldns/ldns.h>


ldns_key_list_new();

bool ldns_key_list_push_key(ldns_key_list *key_list, ldns_key *key);

ldns_key* ldns_key_list_pop_key(ldns_key_list *key_list);

size_t ldns_key_list_key_count(const ldns_key_list *key_list);

ldns_key* ldns_key_list_key(const ldns_key_list *key, size_t nr);

ldns_key_list_new()

ldns_key_list_push_key() pushes a key to a keylist
key_list: the key_list to push to
key: the key to push
Returns false on error, otherwise true

ldns_key_list_pop_key() pops the last rr from a keylist
key_list: the rr_list to pop from
Returns NULL if nothing to pop. Otherwise the popped RR

ldns_key_list_key_count() returns the number of keys in the key list
key_list: the key_list
Returns the numbers of keys in the list

ldns_key_list_key() returns a pointer to the key in the list at the given position
key: the key
nr: the position in the list
Returns the key

The ldns team at NLnet Labs. Which consists out of Jelte Jansen and Miek Gieben.

Please report bugs to ldns-team@nlnetlabs.nl or in our bugzilla at http://www.nlnetlabs.nl/bugs/index.html

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

ldns_key_list, ldns_key. And perldoc Net::DNS, RFC1034, RFC1035, RFC4033, RFC4034 and RFC4035.

This manpage was automaticly generated from the ldns source code by use of Doxygen and some perl.